# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?!\d(\d)\1)[01]+\b/-/gim;t' <<< "0101010, 1010101010
1
1111000"