const regex = /\b(?!\d(\d)\1)[01]+\b/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!\\d(\\d)\\1)[01]+\\b', 'gim')
const str = `0101010, 1010101010
1
1111000`;
const subst = `-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);