$re = '/\b(?!\d(\d)\1)[01]+\b/im';
$str = '0101010, 1010101010
1
1111000';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;