// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.{6}").unwrap();
let string = "uerhfieruhfi eqrhf'dq f
apsokd f
aspokd f
apsodkf
asokdf
ok23 p
4ok23
p4ok23 p
4ko12 p3o4koerg sdf9gi sdfig sdfgi s
dfgo
sdf[pg
sd[ pfgo sd
[pgfo [
gop g[eprg
wrpgo ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}