# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.{6}"
test_str = ("uerhfieruhfi eqrhf'dq f\n"
"apsokd f\n"
"aspokd f\n"
"apsodkf \n"
"asokdf \n"
"ok23 p\n"
"4ok23 \n"
"p4ok23 p\n"
"4ko12 p3o4koerg sdf9gi sdfig sdfgi s\n"
"dfgo\n"
"sdf[pg\n"
"sd[ pfgo sd\n"
"[pgfo [\n"
"gop g[eprg \n"
"wrpgo ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.