$re = '/^.{6}/m';
$str = 'uerhfieruhfi eqrhf\'dq f
apsokd f
aspokd f
apsodkf
asokdf
ok23 p
4ok23
p4ok23 p
4ko12 p3o4koerg sdf9gi sdfig sdfgi s
dfgo
sdf[pg
sd[ pfgo sd
[pgfo [
gop g[eprg
wrpgo ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);