import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.{6}";
final String string = "uerhfieruhfi eqrhf'dq f\n"
+ "apsokd f\n"
+ "aspokd f\n"
+ "apsodkf \n"
+ "asokdf \n"
+ "ok23 p\n"
+ "4ok23 \n"
+ "p4ok23 p\n"
+ "4ko12 p3o4koerg sdf9gi sdfig sdfgi s\n"
+ "dfgo\n"
+ "sdf[pg\n"
+ "sd[ pfgo sd\n"
+ "[pgfo [\n"
+ "gop g[eprg \n"
+ "wrpgo ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}