package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.{6}`)
var str = `uerhfieruhfi eqrhf'dq f
apsokd f
aspokd f
apsodkf
asokdf
ok23 p
4ok23
p4ok23 p
4ko12 p3o4koerg sdf9gi sdfig sdfgi s
dfgo
sdf[pg
sd[ pfgo sd
[pgfo [
gop g[eprg
wrpgo `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}