// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^\s*insert(?:\s+into)?\s+(?<TableName>\[.*?\]|[^ (]+)\s*\((?<Columns>.+?)\)").unwrap();
let string = "insert into [SomeTable]([Run ID]) values (something, something)
insert [SomeTable]([Run ID]) values (something, something)
insert into [SomeTable]([Run ID]) values (something, something)
insert into SomeTable([Run ID]) values (something, something)
insert SomeTable([Run ID]) values (something, something)
insert into SomeTable([Run ID]) values (something, something)
insert into [Some Table]([Run ID]) values (something, something)
insert [Some Table]([Run ID]) values (something, something)
insert into [Some Table]([Run ID]) values (something, something)
insert into [Some Table] ([Run ID]) values (something, something)
insert [Some Table] ([Run ID]) values (something, something)
insert into [Some Table] ( [Run ID],) values (something, something)
insert into [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGineUnitTests].[dbo].TestOdbcReadAndWriteTo([Run ID]) values (something, something)
insert [nGineUnitTests].dbo.TestOdbcReadAndWriteTo ([Run ID]) values (something, something)
insert nGineUnitTests.dbo.TestOdbcReadAndWriteTo ([Run ID]) values (something, something)
insert [nGineUnitTests].dbo.[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)
insert [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ( [Run ID],) values (something, something)
\"This is not an insert statement insert into [dbo].[DoNotAllowNullsString]([Col_umn1]) values (?)\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}