# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*insert(?:\s+into)?\s+(?<TableName>\[.*?\]|[^ (]+)\s*\((?<Columns>.+?)\)"
test_str = ("insert into [SomeTable]([Run ID]) values (something, something)\n"
"insert [SomeTable]([Run ID]) values (something, something)\n"
" insert into [SomeTable]([Run ID]) values (something, something)\n"
"insert into SomeTable([Run ID]) values (something, something)\n"
"insert SomeTable([Run ID]) values (something, something)\n"
" insert into SomeTable([Run ID]) values (something, something)\n"
"insert into [Some Table]([Run ID]) values (something, something)\n"
"insert [Some Table]([Run ID]) values (something, something)\n"
" insert into [Some Table]([Run ID]) values (something, something)\n"
"insert into [Some Table] ([Run ID]) values (something, something)\n"
"insert [Some Table] ([Run ID]) values (something, something)\n"
" insert into [Some Table] ( [Run ID],) values (something, something)\n\n\n"
"insert into [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)\n"
"insert [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)\n"
" insert into [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)\n"
"insert into [nGineUnitTests].[dbo].TestOdbcReadAndWriteTo([Run ID]) values (something, something)\n"
"insert [nGineUnitTests].dbo.TestOdbcReadAndWriteTo ([Run ID]) values (something, something)\n"
" insert nGineUnitTests.dbo.TestOdbcReadAndWriteTo ([Run ID]) values (something, something)\n"
" insert [nGineUnitTests].dbo.[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)\n"
"insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)\n"
"insert [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)\n"
" insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)\n"
"insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)\n"
"insert [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)\n"
" insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ( [Run ID],) values (something, something)\n\n\n"
"\"This is not an insert statement insert into [dbo].[DoNotAllowNullsString]([Col_umn1]) values (?)\"")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.