package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^\s*insert(?:\s+into)?\s+(?<TableName>\[.*?\]|[^ (]+)\s*\((?<Columns>.+?)\)`)
var str = `insert into [SomeTable]([Run ID]) values (something, something)
insert [SomeTable]([Run ID]) values (something, something)
insert into [SomeTable]([Run ID]) values (something, something)
insert into SomeTable([Run ID]) values (something, something)
insert SomeTable([Run ID]) values (something, something)
insert into SomeTable([Run ID]) values (something, something)
insert into [Some Table]([Run ID]) values (something, something)
insert [Some Table]([Run ID]) values (something, something)
insert into [Some Table]([Run ID]) values (something, something)
insert into [Some Table] ([Run ID]) values (something, something)
insert [Some Table] ([Run ID]) values (something, something)
insert into [Some Table] ( [Run ID],) values (something, something)
insert into [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGineUnitTests].[dbo].TestOdbcReadAndWriteTo([Run ID]) values (something, something)
insert [nGineUnitTests].dbo.TestOdbcReadAndWriteTo ([Run ID]) values (something, something)
insert nGineUnitTests.dbo.TestOdbcReadAndWriteTo ([Run ID]) values (something, something)
insert [nGineUnitTests].dbo.[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)
insert [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ( [Run ID],) values (something, something)
"This is not an insert statement insert into [dbo].[DoNotAllowNullsString]([Col_umn1]) values (?)"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}