using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*insert(?:\s+into)?\s+(?<TableName>\[.*?\]|[^ (]+)\s*\((?<Columns>.+?)\)";
string input = @"insert into [SomeTable]([Run ID]) values (something, something)
insert [SomeTable]([Run ID]) values (something, something)
insert into [SomeTable]([Run ID]) values (something, something)
insert into SomeTable([Run ID]) values (something, something)
insert SomeTable([Run ID]) values (something, something)
insert into SomeTable([Run ID]) values (something, something)
insert into [Some Table]([Run ID]) values (something, something)
insert [Some Table]([Run ID]) values (something, something)
insert into [Some Table]([Run ID]) values (something, something)
insert into [Some Table] ([Run ID]) values (something, something)
insert [Some Table] ([Run ID]) values (something, something)
insert into [Some Table] ( [Run ID],) values (something, something)
insert into [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGineUnitTests].[dbo].TestOdbcReadAndWriteTo([Run ID]) values (something, something)
insert [nGineUnitTests].dbo.TestOdbcReadAndWriteTo ([Run ID]) values (something, something)
insert nGineUnitTests.dbo.TestOdbcReadAndWriteTo ([Run ID]) values (something, something)
insert [nGineUnitTests].dbo.[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)
insert [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)
insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ( [Run ID],) values (something, something)
""This is not an insert statement insert into [dbo].[DoNotAllowNullsString]([Col_umn1]) values (?)""";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}