import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*insert(?:\\s+into)?\\s+(?<TableName>\\[.*?\\]|[^ (]+)\\s*\\((?<Columns>.+?)\\)";
final String string = "insert into [SomeTable]([Run ID]) values (something, something)\n"
+ "insert [SomeTable]([Run ID]) values (something, something)\n"
+ " insert into [SomeTable]([Run ID]) values (something, something)\n"
+ "insert into SomeTable([Run ID]) values (something, something)\n"
+ "insert SomeTable([Run ID]) values (something, something)\n"
+ " insert into SomeTable([Run ID]) values (something, something)\n"
+ "insert into [Some Table]([Run ID]) values (something, something)\n"
+ "insert [Some Table]([Run ID]) values (something, something)\n"
+ " insert into [Some Table]([Run ID]) values (something, something)\n"
+ "insert into [Some Table] ([Run ID]) values (something, something)\n"
+ "insert [Some Table] ([Run ID]) values (something, something)\n"
+ " insert into [Some Table] ( [Run ID],) values (something, something)\n\n\n"
+ "insert into [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)\n"
+ "insert [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)\n"
+ " insert into [nGineUnitTests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)\n"
+ "insert into [nGineUnitTests].[dbo].TestOdbcReadAndWriteTo([Run ID]) values (something, something)\n"
+ "insert [nGineUnitTests].dbo.TestOdbcReadAndWriteTo ([Run ID]) values (something, something)\n"
+ " insert nGineUnitTests.dbo.TestOdbcReadAndWriteTo ([Run ID]) values (something, something)\n"
+ " insert [nGineUnitTests].dbo.[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)\n"
+ "insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)\n"
+ "insert [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)\n"
+ " insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo]([Run ID]) values (something, something)\n"
+ "insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)\n"
+ "insert [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ([Run ID]) values (something, something)\n"
+ " insert into [nGine Unit Tests].[dbo].[TestOdbcReadAndWriteTo] ( [Run ID],) values (something, something)\n\n\n"
+ "\"This is not an insert statement insert into [dbo].[DoNotAllowNullsString]([Col_umn1]) values (?)\"";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}