// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)moduleName: ["']?github\.com\/(?<depName>[\w\-]+\/[\w\-\.]+)["']?,?\s+version:\s+["']?(?<currentValue>[_\-\.\w]+)["']?"#).unwrap();
let string = " plugins:
plugin-name: { moduleName: github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin, version: v1.3.0 }
plugins:
plugin-name:
moduleName: \"github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin\"
version: 'v1.3.0'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}