using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"moduleName: [""']?github\.com\/(?<depName>[\w\-]+\/[\w\-\.]+)[""']?,?\s+version:\s+[""']?(?<currentValue>[_\-\.\w]+)[""']?";
string input = @" plugins:
plugin-name: { moduleName: github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin, version: v1.3.0 }
plugins:
plugin-name:
moduleName: ""github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin""
version: 'v1.3.0'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}