package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)moduleName: ["']?github\.com\/(?<depName>[\w\-]+\/[\w\-\.]+)["']?,?\s+version:\s+["']?(?<currentValue>[_\-\.\w]+)["']?`)
var str = ` plugins:
plugin-name: { moduleName: github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin, version: v1.3.0 }
plugins:
plugin-name:
moduleName: "github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin"
version: 'v1.3.0'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}