import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "moduleName: [\"']?github\\.com\\/(?<depName>[\\w\\-]+\\/[\\w\\-\\.]+)[\"']?,?\\s+version:\\s+[\"']?(?<currentValue>[_\\-\\.\\w]+)[\"']?";
final String string = " plugins:\n"
+ " plugin-name: { moduleName: github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin, version: v1.3.0 }\n\n"
+ " plugins:\n"
+ " plugin-name:\n"
+ " moduleName: \"github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin\"\n"
+ " version: 'v1.3.0'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}