$re = '/moduleName: ["\']?github\.com\/(?<depName>[\w\-]+\/[\w\-\.]+)["\']?,?\s+version:\s+["\']?(?<currentValue>[_\-\.\w]+)["\']?/m';
$str = ' plugins:
plugin-name: { moduleName: github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin, version: v1.3.0 }
plugins:
plugin-name:
moduleName: "github.com/maxlerebourg/crowdsec-bouncer-traefik-plugin"
version: \'v1.3.0\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);