// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)#(\S+'[\S\s]+'|\S+)").unwrap();
let string = "#343242 #4#32# #4 #ödgködg #Hello:'klf ködsf' kmfsdölfgölkamsf löj";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}