package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)#(\S+'[\S\s]+'|\S+)`)
var str = `#343242 #4#32# #4 #ödgködg #Hello:'klf ködsf' kmfsdölfgölkamsf löj`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}