using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#(\S+'[\S\s]+'|\S+)";
string input = @"#343242 #4#32# #4 #ödgködg #Hello:'klf ködsf' kmfsdölfgölkamsf löj";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}