$re = '/#(\S+\'[\S\s]+\'|\S+)/m';
$str = '#343242 #4#32# #4 #ödgködg #Hello:\'klf ködsf\' kmfsdölfgölkamsf löj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);