const regex = /#(\S+'[\S\s]+'|\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#(\\S+\'[\\S\\s]+\'|\\S+)', 'gm')
const str = `#343242 #4#32# #4 #ödgködg #Hello:'klf ködsf' kmfsdölfgölkamsf löj`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}