import Foundation
let pattern = #"^(.*):\/\/(.*)(:\d+)\/(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://uat42.my.example.com:56/Pizza?slice=2"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1://\2/\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)