package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*):\/\/(.*)(:\d+)\/(.*)$`)
var str = `https://uat42.my.example.com:56/Pizza?slice=2`
var substitution = "\1://\2/\4"
fmt.Println(re.ReplaceAllString(str, substitution))
}