use strict;
my $str = 'https://uat42.my.example.com:56/Pizza?slice=2';
my $regex = qr/^(.*):\/\/(.*)(:\d+)\/(.*)$/mp;
my $subst = '\\1://\\2/\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";