const regex = /^(.*):\/\/(.*)(:\d+)\/(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*):\\\/\\\/(.*)(:\\d+)\\\/(.*)$', 'gm')
const str = `https://uat42.my.example.com:56/Pizza?slice=2`;
const subst = `\1://\2/\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);