# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*):\\/\\/(.*)(:\d+)\\/(.*)$/\1:\/\/\2\/\4/gm;t' <<< "https://uat42.my.example.com:56/Pizza?slice=2"