use strict;
my $str = '1233
1234
1343
1500
1234
2332
2340
2345
2346
READABLE
^[1][2][3][3-9]$|
^[1][2][4-9][0-9]$|
^[1][3-9][0-9][0-9]$|
^[2][0-2][0-9][0-9]$|
^[2][3][0-3][0-9]$|
^[2][3][4][0-5]$';
my $regex = qr/^[1][2][3][4-9]$|^[1][2][4-9][0-9]$|^[1][3-9][0-9][0-9]$|^[2][0-2][0-9][0-9]$|^[2][3][0-3][0-9]$|^[2][3][4][0-5]$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}