import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[1][2][3][4-9]$|^[1][2][4-9][0-9]$|^[1][3-9][0-9][0-9]$|^[2][0-2][0-9][0-9]$|^[2][3][0-3][0-9]$|^[2][3][4][0-5]$";
final String string = "1233\n"
+ "1234\n"
+ "1343\n"
+ "1500\n"
+ "1234\n"
+ "2332\n"
+ "2340\n"
+ "2345\n"
+ "2346\n\n"
+ "READABLE\n"
+ "^[1][2][3][3-9]$|\n"
+ "^[1][2][4-9][0-9]$|\n"
+ "^[1][3-9][0-9][0-9]$|\n"
+ "^[2][0-2][0-9][0-9]$|\n"
+ "^[2][3][0-3][0-9]$|\n"
+ "^[2][3][4][0-5]$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}