package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1][2][3][4-9]$|^[1][2][4-9][0-9]$|^[1][3-9][0-9][0-9]$|^[2][0-2][0-9][0-9]$|^[2][3][0-3][0-9]$|^[2][3][4][0-5]$`)
var str = `1233
1234
1343
1500
1234
2332
2340
2345
2346
READABLE
^[1][2][3][3-9]$|
^[1][2][4-9][0-9]$|
^[1][3-9][0-9][0-9]$|
^[2][0-2][0-9][0-9]$|
^[2][3][0-3][0-9]$|
^[2][3][4][0-5]$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}