#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1][2][3][4-9]$|^[1][2][4-9][0-9]$|^[1][3-9][0-9][0-9]$|^[2][0-2][0-9][0-9]$|^[2][3][0-3][0-9]$|^[2][3][4][0-5]$"
Local $sString = "1233" & @CRLF & _
"1234" & @CRLF & _
"1343" & @CRLF & _
"1500" & @CRLF & _
"1234" & @CRLF & _
"2332" & @CRLF & _
"2340" & @CRLF & _
"2345" & @CRLF & _
"2346" & @CRLF & _
"" & @CRLF & _
"READABLE" & @CRLF & _
"^[1][2][3][3-9]$|" & @CRLF & _
"^[1][2][4-9][0-9]$|" & @CRLF & _
"^[1][3-9][0-9][0-9]$|" & @CRLF & _
"^[2][0-2][0-9][0-9]$|" & @CRLF & _
"^[2][3][0-3][0-9]$|" & @CRLF & _
"^[2][3][4][0-5]$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")