const regex = /^[1][2][3][4-9]$|^[1][2][4-9][0-9]$|^[1][3-9][0-9][0-9]$|^[2][0-2][0-9][0-9]$|^[2][3][0-3][0-9]$|^[2][3][4][0-5]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1][2][3][4-9]$|^[1][2][4-9][0-9]$|^[1][3-9][0-9][0-9]$|^[2][0-2][0-9][0-9]$|^[2][3][0-3][0-9]$|^[2][3][4][0-5]$', 'gm')
const str = `1233
1234
1343
1500
1234
2332
2340
2345
2346
READABLE
^[1][2][3][3-9]\$|
^[1][2][4-9][0-9]\$|
^[1][3-9][0-9][0-9]\$|
^[2][0-2][0-9][0-9]\$|
^[2][3][0-3][0-9]\$|
^[2][3][4][0-5]\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}