import Foundation
let pattern = #"\burl\((?<url>[^()]+)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
@font-face {
font-family: "JetBrains Mono";
font-style: normal;
font-weight: 400;
src: local("JetBrainsMono-Regular"),
url(JetBrainsMono/JetBrainsMono-Regular.ttf) format("truetype");
}
@font-face {
font-family: "JetBrains Mono";
font-style: normal;
font-weight: 700;
src: local("JetBrainsMono-Bold"),
url(JetBrainsMono/JetBrainsMono-Bold.ttf) format("truetype");
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)