using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\burl\((?<url>[^()]+)\)";
string input = @"@font-face {
font-family: ""JetBrains Mono"";
font-style: normal;
font-weight: 400;
src: local(""JetBrainsMono-Regular""),
url(JetBrainsMono/JetBrainsMono-Regular.ttf) format(""truetype"");
}
@font-face {
font-family: ""JetBrains Mono"";
font-style: normal;
font-weight: 700;
src: local(""JetBrainsMono-Bold""),
url(JetBrainsMono/JetBrainsMono-Bold.ttf) format(""truetype"");
}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}