// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\burl\((?<url>[^()]+)\)").unwrap();
let string = "@font-face {
font-family: \"JetBrains Mono\";
font-style: normal;
font-weight: 400;
src: local(\"JetBrainsMono-Regular\"),
url(JetBrainsMono/JetBrainsMono-Regular.ttf) format(\"truetype\");
}
@font-face {
font-family: \"JetBrains Mono\";
font-style: normal;
font-weight: 700;
src: local(\"JetBrainsMono-Bold\"),
url(JetBrainsMono/JetBrainsMono-Bold.ttf) format(\"truetype\");
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}