import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\burl\\((?<url>[^()]+)\\)";
final String string = "@font-face {\n"
+ " font-family: \"JetBrains Mono\";\n"
+ " font-style: normal;\n"
+ " font-weight: 400;\n"
+ " src: local(\"JetBrainsMono-Regular\"),\n"
+ " url(JetBrainsMono/JetBrainsMono-Regular.ttf) format(\"truetype\");\n"
+ "}\n"
+ "@font-face {\n"
+ " font-family: \"JetBrains Mono\";\n"
+ " font-style: normal;\n"
+ " font-weight: 700;\n"
+ " src: local(\"JetBrainsMono-Bold\"),\n"
+ " url(JetBrainsMono/JetBrainsMono-Bold.ttf) format(\"truetype\");\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}