$re = '/\burl\((?<url>[^()]+)\)/m';
$str = '@font-face {
font-family: "JetBrains Mono";
font-style: normal;
font-weight: 400;
src: local("JetBrainsMono-Regular"),
url(JetBrainsMono/JetBrainsMono-Regular.ttf) format("truetype");
}
@font-face {
font-family: "JetBrains Mono";
font-style: normal;
font-weight: 700;
src: local("JetBrainsMono-Bold"),
url(JetBrainsMono/JetBrainsMono-Bold.ttf) format("truetype");
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);