// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(-|\+)??(180(\.0+?)??|(1[0-7]|\d)\d??(\.\d+?)??)$").unwrap();
let string = "// Valid longitude values
180
180.000
179
179.0
179.999
100
100.00
100.9
99
99.99
99.0
80
10
10.00
10.99
8
8.9
8.0
1
1.0
1.9
0
0.1
0.9
+180
+180.000
+179
+179.0
+179.999
+100
+100.00
+100.9
+99
+99.99
+99.0
+80
+10
+10.00
+10.99
+8
+8.9
+8.0
+1
+1.0
+1.9
+0
+0.1
+0.9
-180
-180.000
-179
-179.0
-179.999
-100
-100.00
-100.9
-99
-99.99
-99.0
-80
-10
-10.00
-10.99
-8
-8.9
-8.0
-1
-1.0
-1.9
-0
-0.1
-0.9
// Invalid longitude values
181
180.00001
180.1
180.9
-181
-180.00001
-180.1
-180.9
+181
+180.00001
+180.1
+180.9";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}