using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(-|\+)??(180(\.0+?)??|(1[0-7]|\d)\d??(\.\d+?)??)$";
string input = @"// Valid longitude values
180
180.000
179
179.0
179.999
100
100.00
100.9
99
99.99
99.0
80
10
10.00
10.99
8
8.9
8.0
1
1.0
1.9
0
0.1
0.9
+180
+180.000
+179
+179.0
+179.999
+100
+100.00
+100.9
+99
+99.99
+99.0
+80
+10
+10.00
+10.99
+8
+8.9
+8.0
+1
+1.0
+1.9
+0
+0.1
+0.9
-180
-180.000
-179
-179.0
-179.999
-100
-100.00
-100.9
-99
-99.99
-99.0
-80
-10
-10.00
-10.99
-8
-8.9
-8.0
-1
-1.0
-1.9
-0
-0.1
-0.9
// Invalid longitude values
181
180.00001
180.1
180.9
-181
-180.00001
-180.1
-180.9
+181
+180.00001
+180.1
+180.9";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}