# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(-|\+)??(180(\.0+?)??|(1[0-7]|\d)\d??(\.\d+?)??)$"
test_str = ("// Valid longitude values\n"
"180\n"
"180.000\n"
"179\n"
"179.0\n"
"179.999\n"
"100\n"
"100.00\n"
"100.9\n"
"99\n"
"99.99\n"
"99.0\n"
"80\n"
"10\n"
"10.00\n"
"10.99\n"
"8\n"
"8.9\n"
"8.0\n"
"1\n"
"1.0\n"
"1.9\n"
"0\n"
"0.1\n"
"0.9\n"
"+180\n"
"+180.000\n"
"+179\n"
"+179.0\n"
"+179.999\n"
"+100\n"
"+100.00\n"
"+100.9\n"
"+99\n"
"+99.99\n"
"+99.0\n"
"+80\n"
"+10\n"
"+10.00\n"
"+10.99\n"
"+8\n"
"+8.9\n"
"+8.0\n"
"+1\n"
"+1.0\n"
"+1.9\n"
"+0\n"
"+0.1\n"
"+0.9\n"
"-180\n"
"-180.000\n"
"-179\n"
"-179.0\n"
"-179.999\n"
"-100\n"
"-100.00\n"
"-100.9\n"
"-99\n"
"-99.99\n"
"-99.0\n"
"-80\n"
"-10\n"
"-10.00\n"
"-10.99\n"
"-8\n"
"-8.9\n"
"-8.0\n"
"-1\n"
"-1.0\n"
"-1.9\n"
"-0\n"
"-0.1\n"
"-0.9\n"
"// Invalid longitude values\n"
"181\n"
"180.00001\n"
"180.1\n"
"180.9\n"
"-181\n"
"-180.00001\n"
"-180.1\n"
"-180.9\n"
"+181\n"
"+180.00001\n"
"+180.1\n"
"+180.9")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.