#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(-|\+)??(180(\.0+?)??|(1[0-7]|\d)\d??(\.\d+?)??)$"
Local $sString = "// Valid longitude values" & @CRLF & _
"180" & @CRLF & _
"180.000" & @CRLF & _
"179" & @CRLF & _
"179.0" & @CRLF & _
"179.999" & @CRLF & _
"100" & @CRLF & _
"100.00" & @CRLF & _
"100.9" & @CRLF & _
"99" & @CRLF & _
"99.99" & @CRLF & _
"99.0" & @CRLF & _
"80" & @CRLF & _
"10" & @CRLF & _
"10.00" & @CRLF & _
"10.99" & @CRLF & _
"8" & @CRLF & _
"8.9" & @CRLF & _
"8.0" & @CRLF & _
"1" & @CRLF & _
"1.0" & @CRLF & _
"1.9" & @CRLF & _
"0" & @CRLF & _
"0.1" & @CRLF & _
"0.9" & @CRLF & _
"+180" & @CRLF & _
"+180.000" & @CRLF & _
"+179" & @CRLF & _
"+179.0" & @CRLF & _
"+179.999" & @CRLF & _
"+100" & @CRLF & _
"+100.00" & @CRLF & _
"+100.9" & @CRLF & _
"+99" & @CRLF & _
"+99.99" & @CRLF & _
"+99.0" & @CRLF & _
"+80" & @CRLF & _
"+10" & @CRLF & _
"+10.00" & @CRLF & _
"+10.99" & @CRLF & _
"+8" & @CRLF & _
"+8.9" & @CRLF & _
"+8.0" & @CRLF & _
"+1" & @CRLF & _
"+1.0" & @CRLF & _
"+1.9" & @CRLF & _
"+0" & @CRLF & _
"+0.1" & @CRLF & _
"+0.9" & @CRLF & _
"-180" & @CRLF & _
"-180.000" & @CRLF & _
"-179" & @CRLF & _
"-179.0" & @CRLF & _
"-179.999" & @CRLF & _
"-100" & @CRLF & _
"-100.00" & @CRLF & _
"-100.9" & @CRLF & _
"-99" & @CRLF & _
"-99.99" & @CRLF & _
"-99.0" & @CRLF & _
"-80" & @CRLF & _
"-10" & @CRLF & _
"-10.00" & @CRLF & _
"-10.99" & @CRLF & _
"-8" & @CRLF & _
"-8.9" & @CRLF & _
"-8.0" & @CRLF & _
"-1" & @CRLF & _
"-1.0" & @CRLF & _
"-1.9" & @CRLF & _
"-0" & @CRLF & _
"-0.1" & @CRLF & _
"-0.9" & @CRLF & _
"// Invalid longitude values" & @CRLF & _
"181" & @CRLF & _
"180.00001" & @CRLF & _
"180.1" & @CRLF & _
"180.9" & @CRLF & _
"-181" & @CRLF & _
"-180.00001" & @CRLF & _
"-180.1" & @CRLF & _
"-180.9" & @CRLF & _
"+181" & @CRLF & _
"+180.00001" & @CRLF & _
"+180.1" & @CRLF & _
"+180.9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")