$re = '/^(-|\+)??(180(\.0+?)??|(1[0-7]|\d)\d??(\.\d+?)??)$/m';
$str = '// Valid longitude values
180
180.000
179
179.0
179.999
100
100.00
100.9
99
99.99
99.0
80
10
10.00
10.99
8
8.9
8.0
1
1.0
1.9
0
0.1
0.9
+180
+180.000
+179
+179.0
+179.999
+100
+100.00
+100.9
+99
+99.99
+99.0
+80
+10
+10.00
+10.99
+8
+8.9
+8.0
+1
+1.0
+1.9
+0
+0.1
+0.9
-180
-180.000
-179
-179.0
-179.999
-100
-100.00
-100.9
-99
-99.99
-99.0
-80
-10
-10.00
-10.99
-8
-8.9
-8.0
-1
-1.0
-1.9
-0
-0.1
-0.9
// Invalid longitude values
181
180.00001
180.1
180.9
-181
-180.00001
-180.1
-180.9
+181
+180.00001
+180.1
+180.9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);