re = /\s*-\s*|\s/m
str = 'Uppsägning på grund av arbetsbrist --------- tjänstemän'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result