use strict;
my $str = 'Uppsägning på grund av arbetsbrist --------- tjänstemän';
my $regex = qr/\s*-\s*|\s/mp;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";