package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*-\s*|\s`)
var str = `Uppsägning på grund av arbetsbrist --------- tjänstemän`
var substitution = "-"
fmt.Println(re.ReplaceAllString(str, substitution))
}