using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*-\s*|\s";
string substitution = @"-";
string input = @"Uppsägning på grund av arbetsbrist --------- tjänstemän";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}