$re = '/\s*-\s*|\s/m';
$str = 'Uppsägning på grund av arbetsbrist --------- tjänstemän';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;