// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Z]|[a-z]|\s)+(,\s*(Jr\.|Sr\.|[IV]*))?$").unwrap();
let string = " John Smith, Jr.
Winn Thomas
Mary 3llen Jones
Clyde Franklin, III
wallace firt, the
wimbobimbo ff , VIVIVVVVIIIVIIVVI
s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr.";
let substitution = "Ye Tar Oo Yetaroo3 Uyetar Goffery ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}