# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([A-Z]|[a-z]|\s)+(,\s*(Jr\.|Sr\.|[IV]*))?$/Ye Tar Oo Yetaroo3 Uyetar Goffery /gm;t' <<< " John Smith, Jr.
Winn Thomas
Mary 3llen Jones
Clyde Franklin, III
wallace firt, the
wimbobimbo ff , VIVIVVVVIIIVIIVVI
s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr."